hostap on SuSE 9.0

Mark G. Spencer mspencer
Tue Dec 16 19:26:54 PST 2003

Hi Pavel,

> ------------Original Message------------
> From: Pavel Roskin <proski at>
> To: "Mark G. Spencer" <mspencer at>
> Cc: hostap at
> Date: Tue, Dec-16-2003 2:48 PM
> Subject: Re: Advice on hostap with Red Hat 9 and/or Fedora Core 1?
> On Tue, 16 Dec 2003, Mark G. Spencer wrote:
> > Hi Jon,
> >
> > I'm probably pushing my luck here .. do you know if there are any SuSE
> > 9.0 RPM's?  Searching Google I've found RPM's for the Athlon platform
> > for SuSE 8.2, but that's as close as I've found.  I've tried Mandrake
> > hostap RPM's before and as far as I could tell at the time, nothing
> > happened .. e.g. hostap didn't appear to be installed or running, so I
> > have no idea what those RPM's were supposed to be doing.
> You should rebuild the RPM from source to make it match your kernel.
> Download the source package and use "rpm --rebuild hostap*.src.rpm"
> You may need the do it as root.

I got the latest three hostap archives and tried to run "rpm --rebuild hostap*.src.rpm" and got the following message:

"--rebuild: unknown option"

I then realized you meant to download hostap RPM source, not hostap source?  I haven't found a hostap RPM for SuSE 9.0.

So now I guess I'll try to get hostap running by compiling from scratch.

I unpacked the hostap driver archive and ran "make pccard" .. I got the following errors:

/usr/src/linux/.config: No such file or directory
WARNING: No kernel PCMCIA support found and PCMCIA_PATH is not defined
WARNING: Linux wireless extensions, CONFIG_NET_RADIO, not enabled in kernel

So I followed the suggestion to run "make cloneconfig && make dep" in /usr/src/linux.

Now when I go back and run "make pccard", I get pages of errors regarding "You should not include /usr/include/{linux,asm}/header files directly for the compilation of kernel modules."

One of the suggestions (that I can at least follow) is to run make mrproper, make cloneconfig, and make dep in /usr/src/linux.

I did this, then went back and ran "make pccard" .. I still get the same few pages of errors.

Any ideas on what is going on here?  This is really frustrating trying to decipher all the error messages .. I'm following recommendations in the error messages as best I can, and everything still blows up.  I guess I'll get a beer, burn incense, and listen to soothing ocean sounds.  ;)


More information about the Hostap mailing list