WDS speed issues revisited

Jouni Malinen jkmaline
Sun Apr 13 21:52:32 PDT 2003

On Tue, Apr 08, 2003 at 10:48:16PM -0700, Dave wrote:

> On a hunch I used two cards that had 1.5.6 and did no ram upload on
> bootup...once the first ping packet from AP1 hit AP2 both WDS speeds jumped
> up from 2Mbps to 11Mbps and stayed there even after packets stopped.
> I then tried a 1.5.6 card with no ram upload and a 1.4.9 card ram uploaded
> to 1.5.6 on bootup...sure enough I could talk WDS 4-ADDR but the 1.4.9 card
> was stuck at 2Mbps while the 1.5.6 card jumped to 11Mbps right away.

I was unable to duplicate this. Loading STA f/w 1.5.6 on a card that has
1.4.9 in flash did not change throughput and I was seeing over 6 Mbps
both to and from that card.

> Jouni (or anyone), what is the correct procedure to reinitialize a card
> after a ram upload in order to take advantage of the features of the newer
> FW. I have tried tonight to issue an "iwpriv wlan0 reset 2" thinking that
> might do it but to no avail.

The correct procedure is to just run prism2_srec.. The driver should
reset the card properly after RAM download and no additional resetting
is needed. You can try "iwpriv wlan0 reset 0", which is the lowest level
of resetting that can be done without reverting back to the firmware
version from flash.

If I understood correctly, you were determining TX rate by using some
higher level throughput test, not by looking at which rate was used for
each packet. There are some cases, in which Prism2 cards seem to stop
sending ACK frames. This would show up as dropped throughput even though
frames are actually still being sent at 11 Mbps; they are just being
retransmitted many times.. This could explain some of the issues you
have seen.

I did some more testing on Repeater mode and noticed few bugs in Host AP
driver. RX statistics were not being updated in this mode and actually,
TX errors were not processed at all; so the rate control should not have
dropped rate at all.. I fixed both bugs. I would appreciate it if you
could re-test using the latest CVS version and verify the real TX rate
by looking into both TX and RX statistics in

On Wed, Apr 09, 2003 at 01:54:33AM -0700, Dave wrote:

> 'iwconfig wlan0 rate 11M fixed'
> does not fix the TX rate. In fact once I issue that command for one
> side of
> a WDS link which is currently at 11Mbps, the rate drops to 2Mbps.

I did not see such behavior. Setting rate to fixed 11M seemed to work
fine. However, if you set rate after it has first dropped, it was not
raised when changing configuration. I fixed this so that rate control
data is updated automatically when changing operational rates. With
current CVS version, I was able to first let the rate control code to
drop the rate to 1M and then manually force only 11M to be used. This
forced the rate to stay at 11M even though I was generating TX error for
every 10th frame.

> I think I understand Jean's comment that the RX is controlled by the
> opposite ends TX...but if the opposite ends TX is fixed to 11M then in
> theory wouldn't this ends RX receive at 11M....minus the overhead,
> retrys,
> errors, birds, planes..

Yes. My current theory is that you might have seen the "card stops
ACKing" problem; i.e., retransmissions are eating most of the

> I am at least confident that the displayed speed via iwconfig wlan0 on
> each
> side of the link in WDS/Repeater mode is accurate as I perform data
> transfers each way and it is right at the displayed speed.

STA files in /proc/net/hostap/wlan0 should provide even better
statistics; both for TX and RX. In the end of those files, there are
counters showing number of TX/RX frames at each rate.

> mishap...I now have radios seperated by 2.5 miles and initially get an
> 11Mbps link...which quickly turns into a 1Mbps link as soon as data
> starts
> moving...but that is probably related to fade margin or something
> because I
> do not have perfect LOS...but still it would be great to have it fixed
> at
> 11Mbps and deal with fade and errors and loss as a seperate issue.

Current algorithm used for TX rate controlling is not very good and
getting stuck into 1 Mbps is probably quite common in many environments.
Anyway, at least I was able to manually configure ('iwconfig wlan0 rate
11M fixed') the rate to be fixed at 11 Mbps even on very poor
(simulated) link. Please let me know if current CVS version does not
work for you.

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list