Problems with wireless...unknown source (long)

Praedor Atrebates praedor
Sun Nov 24 11:00:09 PST 2002

I am having problems with wireless connectivity between an IBM Thinkpad with 
prism2-based wireless card using hostap_cs and my desktop with a wusb11 v2.6 
wireless device using the atmel driver.  Both systems are running Mandrake 
8.2, kernel 2.4.18-6mdk.  

I am posting this to three lists because I cannot identify the source of my 
problems.  It could be a systemic problem with Mandrake/kernel-2.4.18 or a 
problem with the atmel or hostap drivers.  I am hoping someone else may be 
running into/has run into the same problem I am.

I am running my wireless connection as ad-hoc and connection sharing a dialup 
connection on my desktop.  My wlan0 card (on the laptop) has IP 
and my usb device on the desktop is eth0 and has IP  On two 
occassions now I have been able to obtain a working wireless connection 
between them and been able to share my modem connection via iptables/NAT - 
but only for segments of hours.  After a few hours (first time around 3, 
second time ~8 hours - overnight), with no change obvious in the state of 
either system, the wireless connection just stops working.  The syslogs of 
each system still indicates they are "connected" but any attempt to ping 
either direction produces destination unreachable messages.  The pings are 
sent to the correct IPs, however.

This has happened to me twice now, over 2 days.  I am wirelessly connected to 
my desktop from my laptop.  The desktop is connected to the net via modem and 
I am browsing/emailing without problems on the laptop.  Suddenly, after 
several hours, the ability to use the web just stops and I also lose the 
ability to communicate between either system.  I look at the logs and there 
are no error messages anywhere to be found.  When this has happened, I have 
tried to restart pcmcia on my laptop and setting up the card again for adhoc 
as before but there is no communication (though my /var/log/syslog contains 

wlan0: Linkstatus=1 (Connected)
wlan0: Linkstatus: BSSID=02:23:cb:28:93:37

over and over (with the BSSID changing periodically at the 3rd octet).  There 
are NO other wireless networks anywhere near where I live (rural) plus my 
house is aluminum-sided.  It is unlikely, given the distance between homes 
here (~.5 mile) that even if a neighbor had a wireless setup (they don't) 
that it could interfer.  No microwave or other possible interferring device 
has been operated/operating when this happens either.

My /etc/hosts on my deskop:	localhost.localdomain	locahost	lapdog

My /etc/hosts on my laptop:	localhost.localdomain	localhost	Stonekeep

My routing tables do not change from the time that the connection is fully 
functional and when it goes down.  On my desktop with the wusb11 I do have to 
manually add a route to my laptop (so far) each time I've started up the 
wireless connection anew in order to get it working inspite of the syslogs 
having Connected messages in them:

route add -net netmask dev eth0

Nothing changes in my iptables either between the time the shared connection 
is working and when it craps out.  I have found that when the adhoc wireless 
connection dies, I cannot do anything to bring it back.  I have had to reboot 
to get it up again (this is likely an atmel problem).  I restart pcmcia 
services on my laptop and do:

iwconfig wlan0 mode ad-hoc essid keep channel 1

and on the desktop I have tried using both iwconfig and/or xvnet to reset the 
adhoc connection, and though the changes seem to take, no successful 
connection ensues (but I do get those wlan0: Linkstatus (connected) messages 
or on the desktop:

vnetusba.c/usb_vnet_ioctl: cmd x8b01 StationState 5, etc, etc.

I have tried changing over to infrastructure mode on both occassions when the 
adhoc connection died. I had begun to wonder if my usb device was bad and not 
transmitting  (I know the prism2 is OK because the usb device is detecting 
its management signals).  The first time I tried this the desktop connected 
to the laptop AP without problems indicating that the usb device was fully 
functional.  The second time this failed (perhaps it is intermittent).  I 
ultimately rebooted both systems, resetup the adhoc and it worked.  I 
anticipate it will fail again after some unknown number of hours.

Upon trying to setup the connection anew (prior to rebooting) the atmel driver 
gives me problems.  Nothing I do will bring back the usb device.  Restarting 
usb, unloading and reloading the modules, unplugging and plugging in the 
device.  If I try to run ifup eth0 it tells me there is no such device but if 
I do ifconfig it shows up.  If I do iwconfig, it usually shows it up as well 
(though sometimes it doesn't show up, only "lo" shows) and setup properly.  
If I then try to run xvnet or lvnet, it tells me that no atmel device was 
found.  I do a depmod -a and I get a bunch of unresolved symbols in most/all 
of the atmel driver modules (I built them specifically with/for the running 
kernel!).  Thus, when this happens I reboot the system to get it back.

Someone has been posting to the Mandrake list about network connections dying 
after some hours with regards to Mandrake 9.0.  So I wonder if I am running 
into something similar here with my wireless setup...or are there driver 
issues?  Which device?  How do I tell?


More information about the Hostap mailing list