Farallon SkyLINE 11Mb partial incompatibility ?

Sorin PAUN Laurentiu-Sorin.Paun
Fri Nov 22 10:00:01 PST 2002

Does anyone tested this card before ? Seems to work fine for hostap, but :
-at only 2Mbs in Managed & Adhoc modes
-at only 11Mbs in Master mode

in fact, iwconfig <dev> rate doesn't have any effect...

And, the second problem, is that I can't set the roaming mode 2... when 
I do:

  prism2_param wlan0 host_roaming 1

I get a SWSUPPORT mismatch error and others like this

wlan0: hfa384x_cmd: entry still in list? (entry=c35a7760, type=0, res=0)
wlan0: hfa384x_cmd: command was not completed (res=0, entry=c35a7760, 
type=0, cmd=0x0121, param0=0xfce2)
wlan0: hfa384x_set_rid: CMDCODE_ACCESS_WRITE failed (res=-110, rid=fce2, 
wlan0: JoinRequest failed

The strange thing is that it doesn't happen always, it worked for a long 
period and it worked two times some days ago.

card details:

cardctl ident

Socket 0:
   product info: "INTERSIL", "HFA384x/IEEE", "Version 01.02", ""
   manfid: 0x0156, 0x0002
   function: 6 (network)

hostap_diag -a wlan0

Host AP driver diagnostics information for 'wlan0'

NICID: id=0x8008 v1.0.1 (HWB3163, Prism II reference with SSF Flash)
PRIID: id=0x0015 v0.3.0
STAID: id=0x001f v0.8.0 (station firmware)

More information about the Hostap mailing list