I can't properly set host_roaming=1 with the hostap driver in managed mode

Sorin Paun Laurentiu-Sorin.Paun
Wed Nov 20 06:46:25 PST 2002


I'm vorking on a userspace handoff daemon that looks at various other 
parameters that the signal level of APs to take the handoff decision

All worked fine, I think that I was using

-wireless extension v15 (kernel 2.4.20-pre11 + iw252_we15-5.diff patch)
-pcmcia-cs 3.2.1
-wireless tools v26-pre2

all that on a SuSE 8.0 system, the card is a Farallon SkyLINE

product info: "INTERSIL", "HFA384x/IEEE", "Version 01.02", ""
manfid: 0x0156, 0x0002

I tried to change my configuration in:

-wireless extension v15 (kernel 2.4.20-rc2 + iw252_we15-5.diff patch)
-pcmcia-cs 3.2.3
-wireless tools v26-pre2

and now I can't arrive to pass the card in ROAMING MODE 2. I've tried 
also various combination between other versions of wireless extension 
(v14, v15), wireless tools (v25,v26), pcmcia (3.2.1, 3.2.3), 
hostap(september, october) and it doesn't work !

When I want to pass the card in ROAMING MODE 2 (by prism2_param wlan0 
host_roaming 1), I get something like this:


wlan0: LinkStatus=1 (Connected)
wlan0: LinkStatus: BSSID=00:02:2d:03:93:4d

after prism2_param call....

wlan0: ScanResults: Reserved=0xd9c0 ScanReason=2
wlan0: JoinRequest: BSSID=00:00:c5:09:5d:6a channel=11
wlan0: Interrupt, but SWSUPPORT0 does not match: 0000 != 8A32 - card 
wlan0: hfa384x_cmd: entry still in list? (entry=c214bd20, type=0, res=0)
wlan0: hfa384x_cmd: command was not completed (res=0, entry=c214bd20, 
type=0, cmd=0x0121, param0=0xfce2)
wlan0: hfa384x_set_rid: CMDCODE_ACCESS_WRITE failed (res=-110, rid=fce2, 
wlan0: JoinRequest failed
wlan0: scheduled card reset
hostap_cs: wlan0: resetting card
prism2_pccard_cor_sreset: original COR 41
prism2_hw_config: initialized in 9576 iterations
wlan0: Channel setting out of range (3)!
prism2_tx_timeout: wake up queue
wlan0: LinkStatus=1 (Connected)
wlan0: LinkStatus: BSSID=00:02:2d:03:93:4d

Does anybody know what is this about? Does it work for you? Just try to 
do this and tell me it it works fine in your configuration :

iwconfig wlan0 mode managed essid any
prism2_param wlan0 host_roaming 1

You can see if the card passed in host_roaming=1 mode doing a iwlist 
scan and looking if particular messages (like wlan0: JoinRequest: 
BSSID=00:02:2d:03:93:4d channel=11) appear in the kernel log.


Sorin PAUN                           mailto:Laurentiu-Sorin.Paun at imag.fr

Doctorant INPG                             http://drakkar.imag.fr/~lpaun

Laboratoire LSR-IMAG, Equipe Drakkar
681, rue de la Passerelle - BP 72          phone: (+33) (0)4 76 82 72 12
38402 St Martin d'H?res Cedex - France       fax: (+33) (0)4 76 82 72 87

More information about the Hostap mailing list