2.99 Not Downloading Hi-Res Audio

C E Macfarlane c.e.macfarlane at macfh.co.uk
Tue Mar 14 16:00:43 PDT 2017

As per title, until today have been using 2.97, tried 2.99 just now and
can't get it to work ...

The log file shows the following:

13919:	Caithream Ciùil - 14/03/2017, BBC Radio Nan Gaidheal, b08h4hy8
14497:	Crunluath - 02/03/2017, BBC Radio Nan Gaidheal, b08h1dph
24066:	Tuesday Folk - 07/03/2017, BBC Radio Scotland, b08h0kg3
10325:	A' Mire ri Mòir - 14/03/2017, BBC Radio Nan Gaidheal, b08h4hy4

INFO: 4 Matching Programmes
WARNING: Could not download programme metadata from
WARNING: Some recording modes were remapped to new values
WARNING: Input mode list remapped from 'dashhigh,flashaachigh,hafhigh' to
WARNING: Please update your preferences
INFO: Checking existence of original version
INFO: dafhigh1,dafhigh2,dafhigh3,dafhigh4,hafhigh1,hafhigh2 modes will be
tried for version original
INFO: Trying dafhigh1 mode to record radio: Caithream Ciùil -
INFO: File name prefix = Caithream Ciuil - 2017-03-14
Can't locate object method "autoflush" via package "FileHandle" at
/opt/share/get_iplayer/get_iplayer line 8517.

Does 2.99 require a Perl package not required by previous versions?  That's
what the message suggests to me at a first glance, but I can't see anything
like that in the Release Notes, only dependencies removed for 2.98.

Regards, Charles.


More information about the get_iplayer mailing list