New radio PIDs, more than 8 characters - "solved"

Alan Milewczyk alan at
Tue Aug 22 09:48:37 PDT 2017

On 22/08/2017 16:56, Vangelis forthnet wrote:
> On Tue Aug 22 15:52:56 BST 2017, Hugh Reynolds wrote:
>> The installer failed in trying to delete perl.exe, atomicparsley.exe and
>> ffmpeg.exe and left me with the PVR manager reporting "Access is 
>> denied."
>> Those three files seem to be undeletable. I am a supervisor but even 
>> that doesn't seem to give me permission to delete those files.
>> Any ideas what I could do now?
> Hi Hugh
> First thing is you seem to have "hijacked" a previous thread, because 
> the title of the thread you posted in (New radio PIDs, more than 8 
> characters - "solved") has nothing to do with your current 
> predicament... You'd better start a new thread titled, e.g., "Windows 
> installation/upgrade problems".
> That thing aside, from looking at
> I can't spot any major changes to the Win installer...

FWIW, I'm on Win7 x64 Ultimate and the upgrade for me was totally 
faultless. I haven't yet upgraded my Win 10 laptop.

> You should begin by supplying some info on 1. The WinOS 
> version/architecture you're using
> 2. The GiP version previously used (prior to updating)
> First thing I'd suggest is REBOOT your machine.
> After loggin back in, inspect in Task manager whether any GiP related 
> processes are running (perl.exe, atomicparsley.exe, ffmpeg.exe) and 
> kill them if they do...
> Try to first uninstall GiP from Control Panel (you may want to back up 
> your GiP user profile found at %USERPROFILE%\.get_iplayer) followed by 
> a reboot, then proceed with a clean re-install of GiP.
> Your problem looks as if it's permissions related, or involving locked 
> processes/files. I would recommend the Unlocker utility 
> which has saved the day for me on numerous occassions, but use it only 
> if you really know what you're doing...

Yes I wondered that, although files can usually be deleted in the 
Windows folders assuming admin privileges are given. If processes are 
running and stop deletion, I'd also suggest something like Unlocker, 
after trying the Task Manager "end process" route. Another issue may be 
faulty sectors on your hard drive as that can stop files being accessed, 
deleted or altered, in which case a CHKDSK may be in order.

> Hopefully a reboot will clear your issue; GiP 3.02 was only released a 
> few days ago, if it's some bug in the installer then I'd expect more 
> reports to come forth... At first glance it only looks as something at 
> your end, but little do I know...
> If all fails, then maybe report your issue over at the support forum, 
> where, hopefully, it'll be addressed by the maintainer himself

I'd have thought that even by now, had there been problems we'd have 
heard about them either here or in the support forum.


PS hope the sun is shining for you in Greece, Vangelis! :-)

This email has been checked for viruses by Avast antivirus software.

More information about the get_iplayer mailing list