dinkypumpkin dinkypumpkin at gmail.com
Wed May 15 15:51:13 EDT 2013

On 15/04/2013 20:19, Pete Beardmore wrote:
> fixed. i very painfully built and installed perl-5.8.0 but with no
> confidence that my hacking of module makefile.pl files to override
> minimum requirements didn't compromise testing in some way, i less
> painfully built and installed 5.8.1. with this i tested the revised
> patches with no issue ..of my own doing

Something I didn't realise at the time is that the current version of 
LWP requires 5.8.1 to build, so there's not much use building 5.8.0.  I 
salute you for going back as far as 5.8.1 to flush out bugs in the web pvr.

> ..perl versions pre 5.8.5 contain a CGI::hidden() which drops all non
> 'standard' hidden element tags, including 'id'. the javascript of the
> cgi references hidden navigation tab options by id, fails and leaves
> tabs in a permanently collapsed state. i've attached another patch which
> fixes this, thus restoring web-pvr compatibility back to at least 5.8.1
> on this topic, is 10 years for backwards compatibility not a little
> excessive? i ask sincerely as i have no idea on what's common in any
> language

Perl's maintainers still nominally support 5.8 (though its days must 
surely be numbered), so we should at least consider whether or not we 
can do the same.  My earlier comment was referring to language features, 
and in that respect there is no reason get_iplayer shouldn't be able 
maintain 5.8 compatibility.  But as you've seen, the web pvr is at the 
mercy of bugs/changes in the CGI module, which complicates matters.  My 
testing indicates that there are more web pvr problems with Perl < 
5.8.8.  I've suggested on GitHub that we just require 5.8.8 as the 
minimum version for the web pvr only and not worry about earlier 
versions.  Nobody installing a DIY Perl for get_iplayer would go with 
5.8, and in recent times I've only come across a couple of 
still-supported systems which have a system Perl < 5.10 (I'm looking at 
you RHEL/CentOS 5 and OSX 10.5), and both of those were at 5.8.8.  If we 
don't care about those laggard systems, we could go further and require 
5.10 (though it isn't strictly necessary). If anyone knows why requiring 
a minimum Perl version of 5.8.8 (or 5.10) for the web pvr would cause 
problems, chime in.

More information about the get_iplayer mailing list