Using --force

Jeremy Nicoll - ml get_iplayer at
Thu Aug 1 12:59:13 EDT 2013

dinkypumpkin <dinkypumpkin at> wrote:

>On 01/08/2013 16:08, Jeremy Nicoll - ml get_iplayer wrote:
>>   get_iplayer "baldi" --type=radio --get --aactomp3 -force

>If the above is a direct copy+paste, then you're missing a hyphen in 
>front of "force", so it would be ignored.

It's a c&p from notes I made at the time, but I'm not sure if I c&p the
command into the notes or retyped it.  And experiments show not only that
the "-force" isn't ignored, but - worse - had an unexpected effect.

I tried this process again for another programme (using the R4 "Tweet of the
Day' as a test as it's only a 2-minute programme, nice and quick!), and of
course you're right about -force not doing a --force, and --force does do
what it's meant to do. 

I tried to replicate what I saw last night, by deliberately issuing the
command with "-force" in it, and each of these did do a refresh first. I was
wondering if somehow that had been treated as "-f", but then I noticed
something else odd... the refetched files were placed in a not previously
extant folder, C:\rce so I was getting result files with names like:


Then I realised that that implies that "-force" has been parsed as if it
meant an "-fo" parameter with value "rce".  Or more likely that the parser
for options starting with just a single hyphen 'stacks' them?  So it WAS a
case of the leading "-f" of "-force" being treated as -f, then the rest
being treated as "-orce" (meaning override the output dir to "rce")?  

I really will need to take extra care not to have any single hyphens!

Jeremy Nicoll - my opinions are my own.

More information about the get_iplayer mailing list