ERROR: RTMP_Connect0 failed to connect socket 10060 (Unknown error)

dinkypumpkin dinkypumpkin at
Sat Nov 17 12:46:49 EST 2012

On 17/11/2012 16:31, nearangel wrote:
> Thanks for taking the time to look at this.  In answer to your
> suggestions I don't do windows updates (in the interests of
> stability).  I've disabled my anti-virus and retried the process on
> both computers and still get the same result.  Any further advice
> welcomed - don't know what else to try.  I've uninstalled get_iplayer
> and reinstalled etc..  I'd be more than happy to follow any steps to
> solve this issue.
>> It suggests some recent update to windows has caused the problems,
>> either windows or anti-virus. Some anti-virus block programs, check
>> rtmpdump isn't blocked or recorded as a virus, might be blocking out
>> going connections on service port 1935. It's something specific to your
>> windows set-up. Check the event logs, anti-virus logs for clues.

If you're using a VPN, it could be the problem.  The bottom line is that 
when you see:

ERROR: RTMP_Connect0, failed to connect socket. 10060 (Unknown error)

it means that Windows can't establish a network connection to the 
requested resource.  Thus, the problem is almost certainly somewhere in 
your setup outside rtmpdump or get_iplayer.  It may one of the things 
Nigel mentioned, or it may be a network problem upstream, or any number 
of other things.  There is no point in re-isntalling get_iplayer.

You can test your port 1935 connectivity outside get_iplayer here:

or here:

If those test apps can't connect on port 1935, then take a look at your 
firewall.  If it's on, turn it off temporarily to at least establish 
whether or not it's the problem.

More information about the get_iplayer mailing list