[PATCH] amba: simplify amba_lookup function

Sascha Hauer s.hauer at pengutronix.de
Wed Sep 2 01:34:23 PDT 2026


On Mon, 31 Aug 2026 20:31:16 +0300, Alexander Shiyan wrote:
> Remove the unnecessary 'ret' variable and return the matching amba_id
> entry directly when the condition is met. This makes the code shorter
> and more readable without changing any functional behavior.
> 
> 

Applied, thanks!

[1/1] amba: simplify amba_lookup function
      https://git.pengutronix.de/cgit/barebox/commit/?id=611a63bcfaf8 (link may not be stable)

Best regards,
-- 
Sascha Hauer <s.hauer at pengutronix.de>




More information about the barebox mailing list