[PATCH v2 04/10] ARM: mvebu: rename PUTC_LL to MVEBU_PUTC_LL
Luca Lauro via B4 Relay
devnull+famlauro93l.gmail.com at kernel.org
Tue Jul 28 10:43:16 PDT 2026
From: Luca Lauro <famlauro93l at gmail.com>
The name PUTC_LL is used by multiple architectures in barebox for their
early low-level UART output helpers. Since these functions differ between
SoCs and are defined in architecture-specific debug_ll headers, using the
same global name can lead to collisions or accidental overrides when
including multiple debug_ll headers.
To avoid such namespace conflicts and to make the origin of the function
explicit, rename the mvebu-specific PUTC_LL to MVEBU_PUTC_LL.
Signed-off-by: Luca Lauro <famlauro93l at gmail.com>
---
include/mach/mvebu/debug_ll.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/mach/mvebu/debug_ll.h b/include/mach/mvebu/debug_ll.h
index cf08776d4f..cd81b27e39 100644
--- a/include/mach/mvebu/debug_ll.h
+++ b/include/mach/mvebu/debug_ll.h
@@ -15,7 +15,7 @@
#define EARLY_UART UARTn_BASE(CONFIG_MVEBU_CONSOLE_UART)
-static inline void PUTC_LL(char c)
+static inline void MVEBU_PUTC_LL(char c)
{
/* Wait until there is space in the FIFO */
while (!(readl(EARLY_UART + UART_LSR) & LSR_THRE))
--
2.47.3
More information about the barebox
mailing list