[PATCH] common: boards: wolfvision: use state_by_alias instead of opencoding
Michael Riesch
michael.riesch at wolfvision.net
Tue May 14 23:29:27 PDT 2024
Hi Ahmad,
Thanks a lot for your patch!
On 5/15/24 08:07, Ahmad Fatoum wrote:
> This introduces no functional change, but makes code a bit more compact.
>
> Cc: Michael Riesch <michael.riesch at wolfvision.net>
> Signed-off-by: Ahmad Fatoum <a.fatoum at pengutronix.de>
> ---
> common/boards/wolfvision/common.c | 6 +-----
> 1 file changed, 1 insertion(+), 5 deletions(-)
>
> diff --git a/common/boards/wolfvision/common.c b/common/boards/wolfvision/common.c
> index f483918cecfe..5484a8ac6b06 100644
> --- a/common/boards/wolfvision/common.c
> +++ b/common/boards/wolfvision/common.c
> @@ -62,11 +62,7 @@ int wolfvision_register_ethaddr(void)
> char mac[ETH_ALEN];
> int ret;
>
> - ret = of_device_ensure_probed_by_alias("state");
Just to be on the safe side: of_device_ensure_probed_by_alias makes sure
that the underlying drivers are probed, right?
> - if (ret)
> - return ret;
> -
> - state = state_by_name("state");
> + state = state_by_alias("state");
state_by_alias, on the other hand, calls only of_find_node_by_alias,
which (as I presume) does not ensure that.
IIRC the of_device_ensure_... magic was necessary in our setup, but I
can give your patch a test during the next round of barebox board code
cleanups.
Best regards,
Michael
> if (!state)
> return -ENOENT;
>
More information about the barebox
mailing list