[PATCH v1 2/3] imx-usb-loader: use proper return code macros
Johannes Zink
j.zink at pengutronix.de
Fri May 5 00:53:07 PDT 2023
It is considered good practice to use EXIT_SUCCESS and EXIT_FAILURE
instead of hardcoding magic values.
No functional changes.
Signed-off-by: Johannes Zink <j.zink at pengutronix.de>
---
scripts/imx/imx-usb-loader.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/scripts/imx/imx-usb-loader.c b/scripts/imx/imx-usb-loader.c
index 17b83b611765..e49c0bea6ca4 100644
--- a/scripts/imx/imx-usb-loader.c
+++ b/scripts/imx/imx-usb-loader.c
@@ -1557,7 +1557,7 @@ int main(int argc, char *argv[])
break;
case 'h':
usage(argv[0]);
- exit(0);
+ exit(EXIT_SUCCESS);
case 'd':
devtype = optarg;
break;
@@ -1571,13 +1571,13 @@ int main(int argc, char *argv[])
w.do_dcd_once = 0;
break;
default:
- exit(1);
+ exit(EXIT_FAILURE);
}
}
if (devtype && strcmp(devtype, "list") == 0) {
list_imx_device_types();
- exit(0);
+ exit(EXIT_SUCCESS);
}
if (devtype && !devpath) {
@@ -1587,7 +1587,7 @@ int main(int argc, char *argv[])
if (optind == argc) {
fprintf(stderr, "no filename given\n");
usage(argv[0]);
- exit(1);
+ exit(EXIT_FAILURE);
}
w.plug = 1;
--
2.39.2
More information about the barebox
mailing list