[PATCH] base: driver: store probe deferred reason in device structure
Ahmad Fatoum
a.fatoum at pengutronix.de
Thu Jul 7 02:38:51 PDT 2022
Hello Johannes,
Title could be made to focus on the purpose of the patch instead of
the mechanism, e.g.:
base: driver: print dev_err_probe message on permanent probe deferral
Some more comments below.
On 07.07.22 10:25, Johannes Zink wrote:
> This ignores prevents probe deferred warnings in the log output and stores the
You probably meant to delete either ignores/prevents here. Also deferred warnings
weren't displayed before already, so this is not newly introduced with this patch.
> probe deferred reason in the device structure.
>
> If a probe is permanently deferred, the last deferral reason why it was displayed.
s/why it was/is/
>
> Other dev_err_probe outputs are displayed as before.
>
> Signed-off-by: Johannes Zink <j.zink at pengutronix.de>
> ---
> drivers/base/driver.c | 53 +++++++++++++++++++++++++++++++++++++------
> include/driver.h | 6 +++++
> 2 files changed, 52 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/base/driver.c b/drivers/base/driver.c
> index 303ca061c..8eb68306f 100644
> --- a/drivers/base/driver.c
> +++ b/drivers/base/driver.c
> @@ -283,6 +283,8 @@ void free_device_res(struct device_d *dev)
> dev->name = NULL;
> free(dev->unique_name);
> dev->unique_name = NULL;
> + if (dev->deferred_probe_reason)
> + kfree(dev->deferred_probe_reason);
kfree and free that it wraps already have a NULL check, so no need to repeat.
> }
> EXPORT_SYMBOL(free_device_res);
>
> @@ -300,6 +302,16 @@ void free_device(struct device_d *dev)
> }
> EXPORT_SYMBOL(free_device);
>
> +
> +static int device_get_deferred_probe_reason(const struct device_d *dev, char **reason)
> +{
> + if (dev->deferred_probe_reason) {
> + *reason = dev->deferred_probe_reason;
> + return 0;
> + } else
> + return 1;
barebox uses Kernel coding style, If the if clause has braces, the else does too.
But int return here is redundant and makes code a bit harder to follow.
You could just return the pointer directly and have users check against NULL.
> +}
> +
> /*
> * Loop over list of deferred devices as long as at least one
> * device is successfully probed. Devices that again request
> @@ -312,6 +324,7 @@ static int device_probe_deferred(void)
> struct device_d *dev, *tmp;
> struct driver_d *drv;
> bool success;
> + char *reason;
>
> do {
> success = false;
> @@ -333,9 +346,12 @@ static int device_probe_deferred(void)
> }
> } while (success);
>
> - list_for_each_entry(dev, &deferred, active)
> - dev_err(dev, "probe permanently deferred\n");
> -
> + list_for_each_entry(dev, &deferred, active) {
> + if (device_get_deferred_probe_reason(dev, &reason))
if (dev->deferred_probe_reason) or if (reason) ? (with reason defined above)
> + dev_err(dev, "probe permanently deferred\n");
> + else
> + dev_err(dev, "probe permanently deferred (%s)\n", reason);
This can lead to quite long lines, e.g.:
40012000.pin-controller at 40012000.of: probe permanently deferred (40012000.pin-controller at 40012000.of: couldn't request clock)
I am fine with either one or two lines, but the device name shouldn't be printed
twice. See below.
> + }
> return 0;
> }
> late_initcall(device_probe_deferred);
> @@ -573,6 +589,17 @@ const void *device_get_match_data(struct device_d *dev)
> return NULL;
> }
>
> +static void device_set_deferred_probe_reason(struct device_d *dev, const struct va_format *vaf)
> +{
> + const char *drv = dev_name(dev);
drv suggests this is related to the driver, but this is just the device name
and not dev->drv.name.
> + char* reason;
Can be dropped in favor of direct assignment below.
> +
> + if (dev->deferred_probe_reason)
No need to check
> + kfree(dev->deferred_probe_reason);
> +
> + reason = basprintf("%s: %pV", drv, vaf);
No need to add the dev_name() prefix into the deferred_probe_reason,
when you can just use dev_err at permanent probe deferral time to have
it printed.
> + dev->deferred_probe_reason = reason;
> +}
> /**
> * dev_err_probe - probe error check and log helper
> * @loglevel: log level configured in source file
> @@ -584,8 +611,12 @@ const void *device_get_match_data(struct device_d *dev)
> * This helper implements common pattern present in probe functions for error
> * checking: print debug or error message depending if the error value is
> * -EPROBE_DEFER and propagate error upwards.
> - * In case of -EPROBE_DEFER it sets also defer probe reason, which can be
> - * checked later by reading devices_deferred debugfs attribute.
> + *
> + * In case of -EPROBE_DEFER it sets the device's defered_probe_reason attribute,
s/defered/deferred/
> + * but does not report an error. The error is recorded and displayed later, if
> + * (and only if) the probe is permanently defered. For all other error codes,
s/ defered/deferred/
> + * it just ouputs the error
s/ouputs/outputs/ the error along with the formatted message.
> + *
> * It replaces code sequence::
> *
> * if (err != -EPROBE_DEFER)
> @@ -606,13 +637,19 @@ int dev_err_probe(const struct device_d *dev, int err, const char *fmt, ...)
> {
> struct va_format vaf;
> va_list args;
> + char* reason;
char *reason
>
> va_start(args, fmt);
> vaf.fmt = fmt;
> vaf.va = &args;
>
> - dev_printf(err == -EPROBE_DEFER ? MSG_DEBUG : MSG_ERR,
> - dev, "error %pe: %pV", ERR_PTR(err), &vaf);
I'd prefer you keep this part. When debugging it can be useful to know
that a probe was deferred, especially when debugging issues related to
it (violated time constraints, inadequate cleanup). Just do your
extra stuff below.
> + //deferred probe, just remember the error reason
Nitpick: Usual coding style is /* deferred... etc */
> + if(err == -EPROBE_DEFER){
whitespace after if. No braces per kernel coding style.
> + device_set_deferred_probe_reason(dev, &vaf);
> + }
> + else {
} else { or rather else without braces.
> + dev_printf(MSG_ERR, dev, "error %pe: %pV\n", ERR_PTR(err), &vaf);
> + }
>
> va_end(args);
>
> @@ -620,6 +657,8 @@ int dev_err_probe(const struct device_d *dev, int err, const char *fmt, ...)
> }
> EXPORT_SYMBOL_GPL(dev_err_probe);
>
> +
> +
> /*
> * device_find_child - device iterator for locating a particular device.
> * @parent: parent struct device_d
> diff --git a/include/driver.h b/include/driver.h
> index b35b5f397..a41e3d478 100644
> --- a/include/driver.h
> +++ b/include/driver.h
> @@ -88,6 +88,12 @@ struct device_d {
> * when the driver should actually detect client devices
> */
> int (*detect) (struct device_d *);
> +
> + /**
Nitpick: Single * (unless it's kerneldoc)
> + * if a driver probe is deferred, this stores the last error
> + **/
Nitpick: Single *
> +
> + char *deferred_probe_reason;
> };
>
> /** @brief Describes a driver present in the system */
Cheers,
Ahmad
--
Pengutronix e.K. | |
Steuerwalder Str. 21 | http://www.pengutronix.de/ |
31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
More information about the barebox
mailing list