[PATCH] ARM: imx: add support for Udoo Neo full
Uwe Kleine-König
u.kleine-koenig at pengutronix.de
Wed Jun 28 01:16:07 PDT 2017
Hello Stefan,
On Tue, Jun 27, 2017 at 09:40:02PM +0200, Stefan Lengfeld wrote:
> > new file mode 100644
> > index 000000000000..9bf480305d70
> > --- /dev/null
> > +++ b/arch/arm/boards/udoo-neo/board.c
> > @@ -0,0 +1,27 @@
> > +/*
> > + * Copyright (C) 2014 Pengutronix, Sascha Hauer
>
> Maybe add or replace your copyright here. At least you have changed some
> strings and function names.
I wonder if a board.c like this is copyrightable at all and don't feel
an urge to eternalize my name there.
> > + * This program is free software; you can redistribute it and/or
> > + * modify it under the terms of the GNU General Public License
> > + * version 2, as published by the Free Software Foundation.
> > + *
> > + * This program is distributed in the hope that it will be useful,
> > + * but WITHOUT ANY WARRANTY; without even the implied warranty of
> > + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> > + * GNU General Public License for more details.
> > + */
> > +
> > +#include <common.h>
> > +#include <init.h>
> > +#include <linux/clk.h>
> > +
> > +static int imx6sx_udoneo_coredevices_init(void)
> > +{
> > + if (!of_machine_is_compatible("fsl,imx6sx-udoo-neo"))
> > + return 0;
> > +
> > + barebox_set_hostname("mx6sx-udooneo");
> > +
> > + return 0;
> > +}
> > +coredevice_initcall(imx6sx_udoneo_coredevices_init);
> > diff --git a/arch/arm/boards/udoo-neo/flash-header-mx6sx-udoo-neo_full.imxcfg b/arch/arm/boards/udoo-neo/flash-header-mx6sx-udoo-neo_full.imxcfg
> > new file mode 100644
> > index 000000000000..176aff49b3ec
> > --- /dev/null
> > +++ b/arch/arm/boards/udoo-neo/flash-header-mx6sx-udoo-neo_full.imxcfg
> > @@ -0,0 +1,124 @@
> > +loadaddr 0x80000000
> > +soc imx6
> > +dcdofs 0x400
>
> I'm always wondering where the magic values in the flash headers are
> coming from. Whether they are copied from u-boot or another
> variant/board or completely self-made or provided by a friendly hardware
> engineer in an Excel sheet ;-) Maybe you can add a comment here or in
> the commit message. But this would be a new convention, because I have
> not seen it in other flash headers yet.
I got it in a patch from Sascha, don't know where he got it from. I
guess it's a mixure of copy-and-paste from other imxcfgs and the RAMs
datasheet.
Best regards
Uwe
--
Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | http://www.pengutronix.de/ |
More information about the barebox
mailing list