[PATCH v2 7/8] mdio_bus: Change PHY's naming scheme

Andrey Smirnov andrew.smirnov at gmail.com
Wed Feb 3 11:23:38 PST 2016


On Tue, Feb 2, 2016 at 11:36 PM, Sascha Hauer <s.hauer at pengutronix.de> wrote:
> On Sun, Jan 31, 2016 at 07:10:12PM -0800, Andrey Smirnov wrote:
>> Change the way PHY devices are named upon creation. This commit replaces
>> sequentialy numbered "/dev/phy%d" with "/dev/mdio%d-phy%02x". This way
>> it is significanlty easier to identify which PHY in real-life (e.g. on a
>> schematic) corresponds to which device in /dev.
>>
>> Also, replace asprintf with xasprintf to provide some form of memory
>> allocation failure checking.
>>
>> Signed-off-by: Andrey Smirnov <andrew.smirnov at gmail.com>
>> ---
>>  drivers/net/phy/mdio_bus.c | 4 +++-
>>  1 file changed, 3 insertions(+), 1 deletion(-)
>>
>> diff --git a/drivers/net/phy/mdio_bus.c b/drivers/net/phy/mdio_bus.c
>> index b74b27e..41bf018 100644
>> --- a/drivers/net/phy/mdio_bus.c
>> +++ b/drivers/net/phy/mdio_bus.c
>> @@ -333,7 +333,9 @@ static int mdio_bus_probe(struct device_d *_dev)
>>       dev_add_param_int_ro(&dev->dev, "phy_addr", dev->addr, "%d");
>>       dev_add_param_int_ro(&dev->dev, "phy_id", dev->phy_id, "0x%08x");
>>
>> -     dev->cdev.name = asprintf("phy%d", _dev->id);
>> +     dev->cdev.name = xasprintf("mdio%d-phy%02x",
>> +                                dev->bus->dev.id,
>> +                                dev->addr);
>
> While at it we can change the phy device name in the same way to be
> consistent:

Yeah, I agree, let's do this. Let me know if I should do v3 patch set.

Thanks,
Andrey



More information about the barebox mailing list