[PATCH 3/8] console: factorise function to get the console by name
Jean-Christophe PLAGNIOL-VILLARD
plagnioj at jcrosoft.com
Fri Sep 27 05:07:35 EDT 2013
On Sep 27, 2013, at 5:05 PM, Sascha Hauer <s.hauer at pengutronix.de> wrote:
> On Fri, Sep 27, 2013 at 10:58:47AM +0200, Jean-Christophe PLAGNIOL-VILLARD wrote:
>> On 10:50 Fri 27 Sep , Sascha Hauer wrote:
>>> On Fri, Sep 27, 2013 at 09:14:13AM +0200, Jean-Christophe PLAGNIOL-VILLARD wrote:
>>>> rename it to console_get_by_name
>>>>
>>>> +struct console_device *console_get_by_name(const char *cname)
>>>> +{
>>>> + struct console_device *cdev;
>>>> + const char *target;
>>>> +
>>>> + for_each_console(cdev) {
>>>> + target = dev_id(&cdev->class_dev);
>>>> + if (strcmp(cname, target))
>>>> + continue;
>>>> + if ((cdev->f_active & (CONSOLE_STDIN | CONSOLE_STDOUT))
>>>> + return cdev;
>>>> + return NULL;
>>>> + }
>>>> + return NULL;
>>>> +}
>>>> +EXPORT_SYMBOL(console_get_by_name);
>>>
>>> I know this patch doesn't change the current behaviour, but a common
>>> function console_get_by_name() should return return the console by name
>>> regardless of whether it's active or not.
>>
>> I change it behaviour later as now this function will check the console
>> feature
>>
>> as the current implemetation do it too but in the wrong way
>>>
>>> For the loadx code this would be a net win aswell. I think this code
>>> should not depend on an active console but the other way round: It
>>> should clear the CONSOLE_STDIN/CONSOLE_STDOUT during loadx operation.
>>> This way we could easily make sure there are no printf message garbling
>>> the line during transfers and still we could have console messages on
>>> other consoles.
>>
>> patch 8 finaly clean it
>
> ?
>
> patch 8/8 is an atmel serial driver specific patch that changes nothing
> in this regard.
>
it's patch 9 I forget to send this one
but put it on the git
> What I mean is that the loadx stuff should do a cdev->active = 0 so that
> during transfers printf is still possible without corrupting the
> transfers. This behaviour is not changed in this series.
yeah I agree
Best Regards,
J.
>
>
> Sascha
>
> --
> Pengutronix e.K. | |
> Industrial Linux Solutions | http://www.pengutronix.de/ |
> Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
> Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
More information about the barebox
mailing list