[PATCH v2 3/3] imx(25,35): save boot location into $boot_loc env.

Sascha Hauer s.hauer at pengutronix.de
Tue Jan 11 04:41:51 EST 2011


On Tue, Jan 11, 2011 at 10:40:16AM +1100, Marc Reilly wrote:
> Saves the boot source into an environment variable so env scripts
> can more easily use boot source information. We could also
> look at the extra information in the MEM_TYPE bits if needed in future,
> but this is good enough for my purposes.
> 
> Note only tested on imx35. I haven't added support for any other variants
> because I'm not familiar with them. (And can't test them anyway).
> 
> Signed-off-by: Marc Reilly <marc at cpdesign.com.au>
> ---
>  arch/arm/mach-imx/Makefile |    1 +
>  arch/arm/mach-imx/boot.c   |   61 ++++++++++++++++++++++++++++++++++++++++++++
>  2 files changed, 62 insertions(+), 0 deletions(-)
>  create mode 100644 arch/arm/mach-imx/boot.c
> 
> diff --git a/arch/arm/mach-imx/Makefile b/arch/arm/mach-imx/Makefile
> index d000683..3b2deaf 100644
> --- a/arch/arm/mach-imx/Makefile
> +++ b/arch/arm/mach-imx/Makefile
> @@ -11,3 +11,4 @@ obj-$(CONFIG_IMX_IIM)	+= iim.o
>  obj-$(CONFIG_NAND_IMX) += nand.o
>  obj-y += speed.o
>  obj-y += devices.o
> +obj-y += boot.o
> diff --git a/arch/arm/mach-imx/boot.c b/arch/arm/mach-imx/boot.c
> new file mode 100644
> index 0000000..560fc76
> --- /dev/null
> +++ b/arch/arm/mach-imx/boot.c
> @@ -0,0 +1,61 @@
> +/*
> + * This program is free software; you can redistribute it and/or
> + * modify it under the terms of the GNU General Public License as
> + * published by the Free Software Foundation; either version 2 of
> + * the License, or (at your option) any later version.
> + *
> + * This program is distributed in the hope that it will be useful,
> + * but WITHOUT ANY WARRANTY; without even the implied warranty of
> + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
> + * GNU General Public License for more details.
> + *
> + * You should have received a copy of the GNU General Public License
> + * along with this program; if not, write to the Free Software
> + * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
> + * MA 02111-1307 USA
> + */
> +
> +#include <common.h>
> +#include <environment.h>
> +#include <init.h>
> +
> +#include <asm/io.h>
> +#include <mach/imx-regs.h>
> +
> +#if defined(CONFIG_ARCH_IMX25) || defined(CONFIG_ARCH_IMX35)
> +static int imx_boot_save_loc(void)
> +{
> +	const char *bootloc = NULL;
> +	uint32_t reg;
> +
> +	reg = readl(IMX_CCM_BASE + CCM_RCSR);
> +
> +	switch ((reg >> CCM_RCSR_MEM_CTRL_SHIFT) & 0x3) {
> +	case 0x03:		/* SD/MMC, I2C, SPI is the source */
> +		bootloc = "expansion";
> +		break;
> +	case 0x01:		/* NAND is the source */
> +		bootloc = "nand";
> +		break;
> +	case 0x00:		/* NOR, OneNand is the source */
> +		bootloc = "weim";
> +		break;
> +	default:
> +		break;
> +	}

This is not exactly what I meant. Your original "nor" and "mmc" strings
were ok. The boards in the tree do not support booting from eeproms (am
I wrong?), so bootloc has the correct value for the boards in the tree.
Now with this patch we have a situation that when somebody adds a board which
can boot from eeprom, he will update this function and "expansion" will
become "mmc" or "eeprom" breaking your environment scripts.

> +
> +	if (bootloc) {
> +		setenv("boot_loc", bootloc);
> +		export("boot_loc");
> +	}

I just asked two collegues about the meaning of a boot_location variable
and they both said this would be the variable where Linux should be
booted from. Maybe barebox_location is a better name?

I already took the first two patches, so you don't have to resend them.

Sascha


-- 
Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 | http://www.pengutronix.de/  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |



More information about the barebox mailing list