Porting to Marvell 88F5182?

Rogan Dawes rogan at dawes.za.net
Sat Jul 31 07:21:43 EDT 2010

On 2010/07/30 9:50 PM, Rogan Dawes wrote:
> Hi folks,
> I am trying to get a decent boot loader running on my DLink DNS323. It
> was shipped with a severely crippled version of U-Boot, forked from
> U-Boot 1.1.1, and heavily bastardized by Marvell.
> I have managed to get just about everything to work, except for the
> flash part, a Spansion S29GL064M90TFIR4 device. Unfortunately, there
> seems to be some strange connections going on, and the standard U-Boot
> CFI code does not recognise it.

Since I'd be chainloading barebox from the existing U-Boot, which does 
support loadb and bootm, it probably makes the most sense initially to 
just skip the lowlevel init, and build a minimal ARM second stage, and 
wrap it in a u-boot image, I think.

I tried using the at91sam9263ek_defconfig, and unsetting 

My CROSS_COMPILE env variable was set to:


I then made it into a uImage using:

mkimage -A arm -O u-boot -T kernel -C none -a 0x800000 -e 0x800000 -n 
"Barebox" -d barebox.bin uImage.bin

Unfortunately, it hung as soon as I tried to execute it in U-Boot:

Marvell> bootm
## Booting image at 00100000 ...
    Image Name:   Barebox
    Image Type:   ARM U-Boot Kernel Image (uncompressed)
    Data Size:    176100 Bytes = 172 kB
    Load Address: 00800000
    Entry Point:  00800000
    Verifying Checksum ... OK

Starting kernel ...

Any suggestions for a better (minimal?) defconfig to start from, or 
other things to try?

Many thanks!


More information about the barebox mailing list