unable to write flashrom, functionality broken?

Dale Walsh dale at daleenterprise.com
Wed Feb 2 02:50:44 EST 2011

On Feb 01, 2011, at 11:28 AM, Larry Finger wrote:

> On 02/01/2011 05:23 AM, Dale Walsh wrote:
>> I had a hard drive failure which forced me to perform a fresh/clean
>> installation of ubuntu 10 on a new drive since the old drive no  
>> longer
>> functions (it was rather old).
>> My use of the b43 software is only for modification of the PCI  
>> ID's of
>> the flashrom and the original installation was provided to me on  
>> the HD.
>> Now I am unable to write the flashrom after the new installation it
>> always reports "write error: Operation Not Supported" and this is  
>> using
>> the same cards I was flashing before, I even tried using
>> a previously modified card and I get the same failure.
>> Since it worked before I can only conclude that the new software is
>> broken and the ability to write is a requirement, can someone help me
>> resolve this please.
> I do not doubt that the SPROM writing function is broken, but I  
> wonder why you
> are needing it now. Why was it necessary to rewrite the SPROM in  
> the first
> place? Once that was done, then it should never need to be done  
> again. Please
> explain what you did and what you are doing now.

Since not all cards are created equal I take a card with specific  
features and functionality, change the ID's to my own for use with my  
own custom drivers which provides added functionality for cards with  
my ID's.

If the cards do not have my ID's they have the basic functionality  
that people are used to seeing, with my ID's they have the ability to  
run in simultaneous dual band mode (2.4ghz and 5ghz adhoc) and I use  
these ID's to ensure that the drivers only work on cards I approve.

My only need for linux is to rebrand the cards with my ID's.

If I understood enough about the write mechanism I would forego the  
b43 code all together and create an app that reads and writes the  
flashrom but the time involved  in sifting through the ubuntu code  
due to it's source structure makes it a daunting task that turns me off.

As before when working in the original installation (provided to me  
as a working installation) I would do the following: (both cat and cp  

sudo su; # become root to avoid permission issues

cd /PATH TO DIR OF ssb_sprom; # I verify ssb_sprom exists in this  

rmmod b43; # unload the driver

cat updated_sprom >ssb_sprom; # write the updated file

This results in write failure under the new installation.

cp updated_sprom >ssb_sprom

This also results in a write failure under the new installation.

> Larry

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/b43-dev/attachments/20110202/03c4f448/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 188 bytes
Desc: This is a digitally signed message part
URL: <http://lists.infradead.org/pipermail/b43-dev/attachments/20110202/03c4f448/attachment.sig>

More information about the b43-dev mailing list