[PATCH 06/11] bcma: add serial console support
Hauke Mehrtens
hauke at hauke-m.de
Wed Aug 10 03:14:24 EDT 2011
On 07/29/2011 11:06 PM, Rafał Miłecki wrote:
> W dniu 29 lipca 2011 23:04 użytkownik Rafał Miłecki <zajec5 at gmail.com> napisał:
>> 2011/7/23 Hauke Mehrtens <hauke at hauke-m.de>:
>>> This adds support for serial console to bcma, when operating on an SoC.
>>>
>>> Signed-off-by: Hauke Mehrtens <hauke at hauke-m.de>
>>> ---
>>> drivers/bcma/bcma_private.h | 8 ++++
>>> drivers/bcma/driver_chipcommon.c | 48 +++++++++++++++++++++++++++
>>> drivers/bcma/driver_chipcommon_pmu.c | 26 ++++++++++++++
>>> drivers/bcma/driver_mips.c | 1 +
>>> include/linux/bcma/bcma_driver_chipcommon.h | 14 ++++++++
>>> 5 files changed, 97 insertions(+), 0 deletions(-)
>>>
>>> diff --git a/drivers/bcma/bcma_private.h b/drivers/bcma/bcma_private.h
>>> index b97633d..22d3052 100644
>>> --- a/drivers/bcma/bcma_private.h
>>> +++ b/drivers/bcma/bcma_private.h
>>> @@ -29,6 +29,14 @@ void bcma_init_bus(struct bcma_bus *bus);
>>> /* sprom.c */
>>> int bcma_sprom_get(struct bcma_bus *bus);
>>>
>>> +/* driver_chipcommon.c */
>>> +#ifdef CONFIG_BCMA_DRIVER_MIPS
>>> +void bcma_chipco_serial_init(struct bcma_drv_cc *cc);
>>> +#endif /* CONFIG_BCMA_DRIVER_MIPS */
>>> +
>>> +/* driver_chipcommon_pmu.c */
>>> +u32 bcma_pmu_alp_clock(struct bcma_drv_cc *cc);
>>> +
>>> #ifdef CONFIG_BCMA_HOST_PCI
>>> /* host_pci.c */
>>> extern int __init bcma_host_pci_init(void);
>>
>> Not sure, what do you think about this, feel free to comment.
>>
>> My idea was to use bcma_private.h for bcma-internal functions. For
>> example, support for PCI host or SoC host, is something "internal" (as
>> I call it) for bcma. Drivers in theory could be separated modules and
>> I use include/linux/bcma/driver_*.h for them.
>>
>> If following this schema, declarations of
>> bcma_pmu_alp_clock
>> bcma_host_pci_init
>> should be in include/linux/bcma/bcma_driver_chipcommon.h
>
> Same goes to the
> bcma_pmu_get_clockcpu
> from patch 07/11.
>
> Sorry for late-noticing this.
>
> I don't have more comments against your patch set :) Hope John will
> take it soon :)
>
This sounds good. I will send a new patch moving the method declaration
to bcma_driver_chipcommon.h for these 3 functions.
Hauke
More information about the b43-dev
mailing list