[PATCH 7/9] mac80211: add parse transmit power envelope element
Johannes Berg
johannes at sipsolutions.net
Fri Jul 23 02:33:03 PDT 2021
On Mon, 2021-05-17 at 16:19 -0400, Wen Gong wrote:
> This patch is to add the transmit power envelope element parse in
> _ieee802_11_parse_elems_crc(), it maybe have more than one transmit
> power envelope element in a beacon.
This is really hard to read.
I'm sure you're aware of
https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches#commit_messages
Also, FWIW, "This patch" language is pointless. We all know we're
talking about a patch. Or maybe even not, we may be reading the commit
later on.
> + case WLAN_EID_TX_POWER_ENVELOPE:
> + if (elems->tx_pwr_env_num >=
> ARRAY_SIZE(elems->tx_pwr_env))
> + break;
>
Seems to me this should do some validation on the actual element? It at
least has to have _one_ octet, afaict?
johannes
More information about the ath11k
mailing list