QCA6174 showing terrible performance when connecting via WPA3-SAE

Kalle Valo kvalo at kernel.org
Thu Apr 25 02:51:15 PDT 2024

Eric Park <me at ericswpark.com> writes:

> Resending as I forgot to CC the mailing list, sorry! I've added some
> more info since the last email.

Thanks. Let's keep the discussion on the list so that others can join.

> On 2024-03-11 11:21, Kalle Valo wrote:
>> But with modern CPUs I would have still expected software encryption to
>> be faster than 20 Mbps so the chances are it can be something else as
>> well.
> I just checked and the laptop has an i5-5200U, but I'm not sure if
> it's the bottleneck. I ran a speedtest while monitoring the load and
> the CPU usage never went past 20-50% or so.

This depends how you measured CPU usage so I would not make any
conclusions from this yet. I also don't know what's the best way to
measure CPU usage from kernel driver point of view.

>> That's a user space decision and depends on what connection manager you
>> use.
> That's the weird part, for some reason I can't get it to force-connect
> via WPA2-PSK. I've tried KDE's network configuration and `nmtui`, but
> when I connect to the network it seems like it tries to negotiate with
> WPA2-PSK first and then "upgrades" to WPA3-SAE. Or at least that's how
> it appears in the network details dropdown if I click on the chevron
> next to the Wi-Fi SSID.

I do not use Network Manager or other connection managers when testing.
It's much more reliable to use wpasupplicant directly and you get full
control. I usually create a custom config file and then start the
supplicant manually. Some pointers:






More information about the ath10k mailing list