Problems with QCA9377 SDIO on NXP i.MX8MPlus SOM

Bastian Krause bst at
Mon Sep 4 07:28:34 PDT 2023

Hi Lukas and everybody else,

On 6/13/23 17:35, Lukas F. Hartmann wrote:
> Gary Bisson <bisson.gary at> writes:
>>> Trying significantly older ath10k from an older kernel is something to
>>> try in case there are recent regressions in ath10k.
>>> I don't have an ath10k SDIO device myself so I don't know the state of
>>> SDIO support in ath10k. Does anyone else from the list know?
>> FYI we have a branch in our repo with the firmware that worked on ath10k
>> at some point [2].
> Thanks, I looked at this FW now and it is exactly the same as the
> "untested" in the ath10k-firmware repo
> So if that worked with ath10k several years ago (when?) I could try to
> reconstruct an older version and try to bisect for a regression, though
> I imagine it will be complicated to make these old versions work with
> APIs that have changed in the meantime in Linux.

I just wanted to check if I understood this correctly and whether this
is still the latest information: The QCA9377 connected via SDIO won't
work with the ath10k driver right now, correct? Neither with [1] nor
with any other known firmware, right?

Thanks for the previous information, by the way. I'm also stuck with a
QCA9377 (Telit module) connected via SDIO and I'm not too keen on using
the qcacld driver. With Kernel 6.5, I see basically the same output as
pasted here [2] with slightly different register dumps.



Pengutronix e.K.                           |                             |
Steuerwalder Str. 21                       |  |
31137 Hildesheim, Germany                  | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

More information about the ath10k mailing list