Network interface taking a long time to come up

Jens Christian Hillerup jc at
Thu Oct 14 00:56:18 PDT 2021


I'm trying to get a QCA6174-based PCIe card online on the NVIDIA Tegra
platform. Running kernel 4.9.253-l4t-r32.6. The card is detected and
visible in lspci (+ lsusb for the Bluetooth parts), but after loading
the ath10k_pci driver it takes about 2 minutes for the network
interface to actually appear.

In fact, it takes so close to 120 seconds that I believe it could be
due to some kind of timeout.

    $ ls -1 /lib/firmware/ath10k/QCA6174/hw3.0/

    $ dmesg
    [    9.932518] ath10k_pci 0004:01:00.0: enabling device (0000 -> 0002)
    [    9.933364] ath10k_pci 0004:01:00.0: pci irq msi oper_irq_mode
2 irq_mode 0 reset_mode 0
    [   10.211615] ath10k_pci 0004:01:00.0: Direct firmware load for
ath10k/pre-cal-pci-0004:01:00.0.bin failed with error -2
    [   10.211835] ath10k_pci 0004:01:00.0: Falling back to user helper
    [   71.009583] ath10k_pci 0004:01:00.0: Direct firmware load for
ath10k/cal-pci-0004:01:00.0.bin failed with error -2
    [   71.009612] ath10k_pci 0004:01:00.0: Falling back to user helper
    [  132.469576] ath10k_pci 0004:01:00.0: qca6174 hw3.2 target
0x05030000 chip_id 0x00340aff sub 11ad:0513
    [  132.469588] ath10k_pci 0004:01:00.0: kconfig debug 0 debugfs 1
tracing 0 dfs 0 testmode 0
    [  132.470831] ath10k_pci 0004:01:00.0: firmware ver
WLAN.RM.4.4.1-00157-QCARMSWPZ-1 api 5 features wowlan,ignore-otp,mfp
crc32 90eebefb
    [  132.550108] ath10k_pci 0004:01:00.0: board_file api 2 bmi_id
N/A crc32 318825bf
    [  134.617280] ath10k_pci 0004:01:00.0: Unknown eventid: 3
    [  134.638886] ath10k_pci 0004:01:00.0: Unknown eventid: 118809
    [  134.643255] ath10k_pci 0004:01:00.0: Unknown eventid: 90118
    [  134.655353] ath10k_pci 0004:01:00.0: htt-ver 3.60 wmi-op 4
htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
    [  134.748641] ath: EEPROM regdomain: 0x6c
    [  134.748659] ath: EEPROM indicates we should expect a direct regpair map
    [  134.748665] ath: Country alpha2 being used: 00
    [  134.748668] ath: Regpair used: 0x6c

I've tried to enable the skip_otp flag while loading ath10k_core, but
that didn't seem to help.  I've also loaded the module with the debug
option, but couldn't deduce where the log lines actually would go.

Also tried to update to the most recent firmware version (4.4.1) to no
avail. One thing I noted there is that it tries to load a file called
firmware-5.bin, which didn't exist:

    ath10k_pci 0004:01:00.0: could not fetch firmware file
'ath10k/QCA6174/hw3.0/firmware-5.bin': -11

For testing, I symlinked the adjacent firmware-6.bin file to
firmware-5.bin which the driver didn't complain about (but was
probably against federal jurisdiction in several countries). The fact
that the driver expected the firmware file to be called firmware-5.bin
could mean that the ath10k driver bundled on my platform is simply too
old and I should look for a backport, perhaps?

Either way, I'd be happy for any pointers as to how to debug this.
Thanks in advance.

Jens Christian

Jens Christian Hillerup software engineer
Head of Engine, Veo Technologies

More information about the ath10k mailing list