Compex WLE200NX: regdomain sanitized regression

Bryce Allen bryce at
Sat Nov 27 08:35:59 PST 2021

I have this issue on my two pcengines APs, one ALIX and one APU2. I 
created some dkms modules for patched ath9k/10k, setting the regdomain 
to CTRY_DEFAULT rather than 0x64. For me this results in US region, not 
sure if it will do the right thing in other regions or not. But you 
could use this as a starting point, and way better than rebuilding 
kernel from scratch each time:

I created trees for 5.10 from Debian Bullseye and for Ubuntu HWE 5.11 
kernel. This is based on tips and DKMS config from sparks71. At one 
point I tried a patch that added a region module parameter, but I got 
kernel faults and never got it to work - the CTRY_DEFAULT fix was 
simpler for me. You can see the patch here:


On 11/27/21 03:17, Sebastian Bachmann wrote:
> Hello,
> I recently upgraded my Debian based AP from buster to bullseye, just 
> to find out that hostapd does not work any more, because all 5GHz 
> channels are marked as No-IR. This regression was already discussed on 
> this ML here: 
> and there is also an entry in Debian's bug tracker for the same issue: 
> I have a slightly different card (branded Compex WLE200NX):
> 04:00.0 Network controller: Qualcomm Atheros AR928X Wireless Network 
> Adapter (PCI-Express) (rev 01)
>         Subsystem: Qualcomm Atheros AR928X Wireless Network Adapter 
> (PCI-Express)
>         Kernel driver in use: ath9k
>         Kernel modules: ath9k
> But as you can see, also the EEPROM gets sanitized:
> [   15.461755] ath9k 0000:04:00.0: enabling device (0000 -> 0002)
> [   15.911600] ath: EEPROM regdomain sanitized
> [   15.911612] ath: EEPROM regdomain: 0x64
> [   15.911615] ath: EEPROM indicates we should expect a direct regpair 
> map
> [   15.911625] ath: Country alpha2 being used: 00
> [   15.911628] ath: Regpair used: 0x64
> I read in the other thread, that this is a regression, but the actual 
> commit causing it was never reverted.
> I tried to search for newer messages explaining the issue, however as 
> far as I can tell, the thread ends in June 2020 with no solution 
> available.
> Therefore, I kindly want to ask if there is any workaround available 
> to re-enable 5GHz channels in AP mode for my card? (expect sticking to 
> a pre-5.6 kernel or manually patching and recompiling ath)
> Best,
> Sebastian
> _______________________________________________
> ath10k mailing list
> ath10k at

More information about the ath10k mailing list