Meshed WiFi with QCA9377 (USB/SDIO)

Peter Åstrand astrand at
Mon Sep 14 09:47:40 EDT 2020

Hi. We are designing an IOT system from scratch and want to select a WiFi 
module that works well with 80211s. ath9k is apparently tried and tested, 
but mostly covers older modules which are no longer available. We are 
evaluating ath10k and in particular QCA9377. Does that sound like a good 
choice, or do you have any other recommendations?

For the final board, we are planning to use QCA9377-3 (SDIO). As I 
understand it, this should work with Linux 5.7 and later? We will test 
using soon.

In the mean time, I tried to test QCA9377-7 (USB) using unfortunately without success. 
I started out with Linux 5.7 and modified usb.c:

---	2020-09-14 11:58:10.905346540 +0200
+++ usb.c	2020-09-14 15:39:51.555416792 +0200
@@ -1083,6 +1083,7 @@
  /* table of devices that work with this driver */
  static struct usb_device_id ath10k_usb_ids[] = {
  	{USB_DEVICE(0x13b1, 0x0042)}, /* Linksys WUSB6100M */
+	{USB_DEVICE(0x0cf3, 0xe500)}, /* 8devices BLUE bean */
  	{ /* Terminating entry */ },

Unfortunately this did not work: ath10k_usb is loaded but, but no net 
device is created. No error messages; nothing. Firmware package is Debian 
10 firmware-atheros 20190114-2. I also noticed and 
as far as I can tell, this was never merged.

Peter Åstrand

More information about the ath10k mailing list