Support for QCA9377

Jay Foster jayf0ster at
Tue May 15 15:17:31 PDT 2018

On 5/14/2018 1:09 PM, Gangadharan Vemula wrote:
> On Mon, May 14, 2018 at 12:50 PM, Patrick Doyle <wpdster at> wrote:
>> On Mon, May 14, 2018 at 3:28 PM, Gangadharan Vemula
>> <gangadharan at> wrote:
>>> Hi,
>>> Silex patch-set was applied to master-pending branch of ath.git. Now,
>>> it is in the process of getting into mainline, Mr. Kvalo is working on
>>> it.
>> Thank you.  I will check that out.
> Removed from master-pending branch and new branch has been created for
> ath10k-sdio-usb,
> I hope this is the base-branch for ath10k-sdio-usb. But, we (silex)
> didn't verify anything on this branch yet.
> Not sure, whether Mr.Kvalo is using this (ath10k-pending-sdio-usb)
> branch for testing.
I too have been, off and on, looking for an ath10k driver solution for a 
SparkLAN WUBQ-159ACN USB Wi-Fi adapter, so I have been keeping an eye on 
this mailing list.  I just tried the latest ath10k-pending-sdio-usb 
branch (ath10k-pending-sdio-usb-201804210910 tag), since I could see 
that support for the SparkLAN USB 0CF3:9378 device was just added.  The 
driver refers to this as the SparkLAN WPEQ-160ACN device, but it has the 
same USB vendor/product ID as my WUBQ-159ACN.  They both use the QCA9377 

I got a driver to build with the 4.9 kernel and when it boots, it 
recognizes my Wi-Fi adapter.  Now, I am trying to sort out what to do 
about firmware.  I downloaded the board-2.bin, board.bin, firmware-5.bin 
files from 
I used the ath10k-fwencoder application from the qca-swiss-army-knife 
tools to also build a firmware file, but I am not clear on what files I 
should be using.  SparkLAN provided, with the qcacld-2.0 wlan driver, 
the following files:
athsetup.bin, athwlan.bin, cfg.dat, fakeboar.bin, otp.bin, and 
qcom_cfg.ini.  I used the command:

qca-swiss-army-knife/tools/scripts/ath10k/ath10k-fwencoder --create 
--otp ../../../otp.bin --firmware ../../../athwlan.bin 
--set-wmi-op-version=tlv --set-htt-op-version=tlv --set-fw-api=6 

to create my firmware-usb-6.bin and used the fakeboar.bin for my 
board-usb.bin files.  However, when the driver loads, it is looking for 
a file called ath10k/cal-usb-1-1.2.bin.  Where do I get that file?  I 
tried using the athsetup.bin file for this, but I do not think that 
works.  The driver reports:

/lib/firmware/ath10k/QCA9377/hw1.0# usb 1-1.2: qca9377 hw1.1 SparkLAN 
WPEQ-160ACN target 0x05020001 chip_id 0x00000000 sub 0000:0000
usb 1-1.2: kconfig debug 1 debugfs 0 tracing 0 dfs 0 testmode 1
usb 1-1.2: firmware ver  api 6 features ignore-otp crc32 e8985f67
usb 1-1.2: found invalid board magic
usb 1-1.2: board_file api 1 bmi_id N/A crc32 58a139e9
usb 1-1.2: invalid hw_params.n_cipher_suites 0

What does invalid board magic mean?
The Wi-Fi USB adapter may be installed in any number of different USB 
locations, so why is the USB location (1-1.2) part of one of the filenames?


More information about the ath10k mailing list