Bad TCP performance on WLE900VX

Kalle Valo kvalo at
Thu Jan 4 06:38:14 PST 2018

Robert Jones <rjones at> writes:

> Hello Everyone,
> I'm using a custom arm64 board with a Cavium CN8030 CPU and testing
> wireless card performance via iperf on Ubuntu 16.02 with a mainline
> 4.14 kernel. I have two identical units connected to each other via
> 60dB attenuators on all three channels. Channel is set to 161 VHT80.
> With UDP I see throughput upwards of 650Mbits/s, but TCP is
> ~24Mbits/s. That seemed odd so I did a little more testing. Switched
> to a 4.9 kernel and still saw the poor performance, but not with a
> 4.4. Before I went through the trouble of bisecting I thought to ask
> if there was something I was missing.
> I did come across this Ubuntu bug thread
> [] which
> appeared to follow the same behavior I was seeing. Switched my TCP
> congestion algorithm to reno and saw throughput jump to >330Mbits/s.
> Cubic and BBR still ~24.
> My question now, is there a standing bug that I'm not aware of or
> could there be some sort of problem with my configuration that is
> being worked around with the reno algorithm?

There's now support in TCP stack (commit below) to workaround this issue
in ath10k. I tried to come up with a patch before holidays but didn't
make it, anyone willing to write one?

tcp: allow drivers to tweak TSQ logic

Kalle Valo

More information about the ath10k mailing list