ath10k + iw set bitrates is causing FW crash

Krishna Chaitanya chaitanya.mgit at
Fri Jul 22 07:48:14 PDT 2016

On Fri, Jul 22, 2016 at 7:02 PM, Ben Greear <greearb at> wrote:
> On 07/22/2016 05:21 AM, Krishna Chaitanya wrote:
>> On Fri, Jul 22, 2016 at 5:29 PM, Manoharan, Rajkumar
>> <rmanohar at> wrote:
>>> [...]
>>>>>> Thanks Raj, with this fix the rates are 0-7, if i disable then i am
>>>>>> seeing 0-9, so its
>>>>>> working.
>>>>>> But i am seeing a weird issues, the moment i give bitrates command,
>>>>>> ath10k no longer does encryption, link is a WPA2-PSK: AES. Even after
>>>>>> interface up/down
>>>>>> it doesn't work.
>>>>> After reboot i dont see the "unencrypted" packet issue, i will do
>>>>> some more testing on limiting the rates, currently in my setup its
>>>>> not reaching MCS9 so cannot verify now.
>>>> Rajkumar,
>>>> I am still not able to make mcs9 work, so i have tried to change the Nss
>>>> to 1
>>>> using iw, but that is not taking affect. This command is not taking
>>>> effect.
>>> you mean not able to fix VHT rates alone. am i right? By auto rate mode,
>>> is firmware selecting
>>> mcs9? What is the command used for fixing vht rate?
>> Basically my requirement is to disable MCS8 and 9 for comparison.
>> to check whether ath10k honors the iw command, i used below
>> command. changing to 1SS, but i could see that it still transmits
>> using 2SS. Does your patch ignore these settings except for
>> adhoc mode?
>> iw set bitrates vht-mcs-5 1:0-7
> You can set the number of spatial streams on the phy device.  Search around
> for a 'chainmask' configurable.
> In general, stock ath10k firmware does not have full support for setting
> arbitrary bitrates options.
Yes, i know that option but havent tried that. My intention was to limit to MCS7
so in order to verify that commands i tried to change nss.

More information about the ath10k mailing list