Link can't get estabilished over RB911AC boards

Alessandro Bolletta alessandro at
Mon Sep 21 12:57:11 PDT 2015


I have two Mikrotik RB911AC boards (radio based on QCA9882) in which I injected OpenWRT 15.05 and ath10k. 

I managed to get them connected in AP/STA configuration in a very short (2 meters) distance, but when I try to connect them on 5 kilometers, even if I set the distance parameter on OpenWRT's UCI config files properly, it tries to connect but after 3 retries, it declares unauthenticated.

No problem with the same firmware on ath9k, for example.
Signal is stable at -62 dbm, I also tried to change channels and push tx power, but nothing helped to do the trick.
Also tried with every firmware combination (10.2.4, CT firmware, 999.999.0.636, 10.1.467.2-1), without success.

Is there anybody who can tell me why? Could it be due to the kernel version (i'm running on 3.18.21)?

Thanks in advance,

Alessandro Bolletta
Mediaspot Srl

More information about the ath10k mailing list