More than one ath10k NIC in 3.19.0-rc5?

Ben Greear greearb at
Wed Jan 21 11:47:05 PST 2015

On 01/21/2015 11:01 AM, Ben Greear wrote:
> On 01/20/2015 06:49 PM, Ben Greear wrote:
>> On 01/20/2015 06:13 PM, Sebastian Gottschall wrote:
>>> Am 20.01.2015 um 22:53 schrieb Ben Greear:
>>>> I tried running a patched version of 3.19.0-rc5 kernel, and it seems to work
>>>> fine when there is one ath10k NIC in the system, but when there is two it
>>>> doesn't try to load the firmware.
>>>> Hacked 3.17.8+ works fine.
>>>> Anyone tried more than one ath10k NIC in 3.19 kernel?
>>>> Thanks,
>>>> Ben
>>> standard x86 system? i just can say that with 3.18 i have big troubles with the new pci bus code introduced on several embedded devices.
>>> so maybe the reason is here?
>> Standard 64-bit x86.
> Looks like 3.19.0-rc2 is OK, -rc5 is busted.  I'll bisect...

Err, no.  rc2 is busted too...sometimes first NIC loads, sometimes
second, but not both at once....doing bigger bisect...


Ben Greear <greearb at>
Candela Technologies Inc

More information about the ath10k mailing list