[PATCH/RFT 2/2] ath10k: rename qca6174 to qca61x4

Kalle Valo kvalo at qca.qualcomm.com
Fri Aug 14 01:27:23 PDT 2015

Michal Kazior <michal.kazior at tieto.com> writes:

> This cleans up the naming a little bit. Both
> QCA6174 and QCA6164 are in practice the same as
> far as driving them is concerned.
> Unfortunately firmware paths will need to stay
> untouched, i.e. QCA6164 firmware will still be
> looked for in QCA6174 to avoid breaking backward
> compatibility with older /lib/firmware setups.
> Signed-off-by: Michal Kazior <michal.kazior at tieto.com>

This is purely cosmetics and only visible to developers, users won't
notice anything, so I'm not sure if this is worth the trouble. With
proper documentation I would hope that any developer will realise that
QCA6174 actually also means QCA6164 support :)

And more to the point there is nothing preventing coming up with a new
version with a name like QCA6964 or QCA9121 so the prefix would be wrong
again. This has happened with ath6kl in the past.

> --- a/drivers/net/wireless/ath/ath10k/core.c
> +++ b/drivers/net/wireless/ath/ath10k/core.c
> @@ -63,49 +63,49 @@ static const struct ath10k_hw_params ath10k_hw_params_list[] = {
>  		},
>  	},
>  	{
> -		.id = QCA6174_HW_2_1_VERSION,
> -		.name = "qca6174 hw2.1",
> -		.patch_load_addr = QCA6174_HW_2_1_PATCH_LOAD_ADDR,
> +		.id = QCA61X4_HW_2_1_VERSION,
> +		.name = "qca61x4 hw2.1",

What if we instead change the name to "qca6164/qca6176 hw2.1" or
something like that. Would that help?

Kalle Valo

More information about the ath10k mailing list