Timeout Issues

Michal Kazior michal.kazior at tieto.com
Thu Sep 4 01:16:40 PDT 2014

On 2 September 2014 20:51, Pushpal Sidhu <psidhu at gateworks.com> wrote:
> Sorry for the amazingly late reply, other things crept into my schedule.
> The board has 9 port PCI-e switch behind the RC. I did, however, use
> the same slot. I found that there was always 1 interrupt, but never
> any more. This made me think a bit more and found that if I set
> PCI_MSI=n in the kernel config, the problem 'goes away' and I see
> increasing number of interrupts and do not see anymore of the '-110'
> error messages. This issue, for me, is solved as I don't necessary
> need mixed signaled interrupts, but I'm unsure of why this is
> happening and what is different about the Intel 7260HMW card from the
> Atheros cards or in their respective drivers.

Hmm.. Your original logs suggest ath10k was already running in
legacy/shared irq mode before which means it already tried MSI and

> [    5.233469] ath10k_pci 0000:09:00.0: enabling device (0140 -> 0142)
> [    5.575954] ath10k: pci irq legacy irq_mode 0 reset_mode 0

I wonder if the Intel card succeeds to pci_enable_msi(). Perhaps this
is a bug with QCA988X failing to recover from a failed MSI negotiation
with the PCI-E controller?

You could try adding irq_mode=1 parameter to ath10k_pci module. This
way you'll force ath10k to use shared interrupts without even trying
to go through MSI->shared failover and if I'm right you won't need the
PCI_MSI=n in your kernel.


More information about the ath10k mailing list