Unicast packets stop being transmitted to a particular station, under load, when WPA2 is enabled

Avery Pennarun apenwarr at gmail.com
Sun May 11 22:19:24 PDT 2014

On Mon, May 12, 2014 at 1:05 AM, Ben Greear <greearb at candelatech.com> wrote:
> If it's getting on the air, then I think the only way to figure out
> what is wrong is to decode the packets and see if they are encrypted
> properly or not.  I think there is a way to get wireshark to decode
> pkts by feeding it the proper keys, but I have not ever actually tried
> doing that.
> If pkts do not get on the air, then possibly the tx status and/or tx
> error counters could tell you why, but it seems that is not relevant
> in this case.

Okay, in fact I just learned how to use that wireshark feature last
week, so I tried it just now and it worked.  It clearly shows the
downstream packets from the AP *are* decryptable from wireshark, but
they get no replies from the macbook (and the macbook doesn't show
them at its IP layer).

Any guesses?  Does that mean somehow the macbook got the wrong
*decryption* keys or something?

I'm currently trying to wade through the giant wireshark capture
trying to find the actual point where the dropout occurred, but it
seems to slow down a bit with 1.5 million frames captured :)

More information about the ath10k mailing list