Timeout Issues

Pushpal Sidhu psidhu at gateworks.com
Tue Aug 19 14:33:44 PDT 2014

On Tue, Aug 19, 2014 at 11:42 AM, Ben Greear <greearb at candelatech.com> wrote:
> Have you tried a WLE900 VX NIC?  Those have worked well for me.

I haven't yet, though I'll get my hands on one to try out.  I have
tried a WLE900N5-20 with the
same results below, however.

>> I am using the following software on an ARM board:
>> ath10k branch of linux kernel: 3.16.0-wl-ath-182333-g6a69f0c
>> latest git of hostapd
>> latest git of iw
>> latest git of wpa_supplicant
>> I have tried both firmware-2 binary blobs (the "AP" and "STA"
>> versions) as well as the newer firmware-3 binary with the same exact
>> messages being displayed.
> Probably this is not a firmware issue, but if you have nothing else
> to try, you can try my version of the 10.1.x firmware:
> http://www.candelatech.com/ath10k.php
> and possibly my hacked 3.14.14 kernel, which may spew out some additional
> debug info if you have something like OTP issues.
> git clone git://dmz2.candelatech.com/linux-3.14.dev.y

With the Kernel I was using (the 3.16.0-wl-ath-x-x), your firmware
produced the following:
[    5.466186] ath10k: Unknown FW IE: 5

and then output the same timed out messages. The upstream ath10k
driver that I'm using is
looking for firmware-3.bin it seems.

I cloned your kernel and built it, but was having the same exact
errors I posted before (no extra
debug info). One interesting thing I found is if I use OpenWrt trunk,
ath10k seems to behave fine,
but another distro seems to break things. I'll need to dig further
into that, but in the mean time, do
you have any thoughts?

- Pushpal

More information about the ath10k mailing list