Timeout Issues

Pushpal Sidhu psidhu at gateworks.com
Tue Aug 19 11:27:23 PDT 2014


I'm having issues with ath10k timing out when trying to communicate
with the wireless card (UNEX DAXA-O1 + have tried several others).
Below is what I grabbed from dmesg.

$ dmesg | grep ath10k
[    5.233469] ath10k_pci 0000:09:00.0: enabling device (0140 -> 0142)
[    5.575954] ath10k: pci irq legacy irq_mode 0 reset_mode 0
[    7.704403] ath10k: failed to receive control response completion, polling..
[    8.704379] ath10k: Service connect timeout: -110
[    8.709089] ath10k: failed to connect htt (-110)
[    9.020495] ath10k: could not init core (-110)
[    9.324371] ath10k: could not probe fw (-110)

This causes the card to not be registered, and thus is unusable (there
is no wlanX)

I am able to use the Intel 7260 card (another AC card) with their
firmware binary blob, so I don't believe this is a hardware
configuration issue with mini-pcie.

I am using the following software on an ARM board:
ath10k branch of linux kernel: 3.16.0-wl-ath-182333-g6a69f0c
latest git of hostapd
latest git of iw
latest git of wpa_supplicant

I have tried both firmware-2 binary blobs (the "AP" and "STA"
versions) as well as the newer firmware-3 binary with the same exact
messages being displayed.

Any help towards finding a solution is appreciated, thanks!

- Pushpal Sidhu

More information about the ath10k mailing list