Report Firmware firmware-2.bin_10.1.467.2-1 Error

Michal Kazior michal.kazior at
Thu Apr 24 02:41:34 PDT 2014

On 24 April 2014 11:03, Vu Hai NGUYEN <vh.nguyen at> wrote:
> Thank you for your response, the problem is solved when I download the latest version of backport (3.15) and compile ath10k with it (last time my version is 3.13 and as you said, It might not include the patch).
> Now I can load the firmware 10.1.467.2-1 but I get new problem too.
> Does ath10k support all the command of "iw"?
> For example I set up mode access point and tried to change the txpower by the command: "iw wlan0 set txpower fixed 1200" (same thing as "iwconfig wlan0 txpower 12dBm" , right?)
> The output of "iwconfig" is:
> wlan0     IEEE 802.11abgn  Mode:Master  Tx-Power=12 dBm
>           Retry short limit:7   RTS thr:off   Fragment thr:off
>           Power Management:on
> And output of "dmesg":
> ath10k: mac config power 12
> ath10k: wmi pdev set param 3 value 24
> ath10k: wmi pdev set param 4 value 24
> It seems that the command arrives until the level of driver ath10k and works but when I verified by connecting a station to my access point and look at the out put of "iw wlan0 station dump", the value of txpower received at the station didn't change even when I changed the txpower of my access point from 1dBm to 20dBm (my station is near the access point).

This works for me (latest with 467.2).

I can see "signal" values change in iw station dump on the connected
client when I set different txpower values on ath10k AP.

> Same thing when I do with the command set bit rates: "iw wlan0 set bitrates legacy-2.4 54 ht-mcs-2.4"
> Out put of dmesg:
> ath10k: mac fixed rate pream 0x00 nss 0x00 rate 0x04
> ath10k: wmi vdev id 0x0 set param 27 value 4
> ath10k: wmi vdev id 0x0 set param 34 value 1
> ath10k: wmi vdev id 0x0 set param 28 value 0
> ath10k: wmi event debug mesg len 16
> But the out put of " iw wlan0 station dump" did not show any change when I varied the bit rate of my access point too.

Again, this works for me.

To be clear - ath10k is incapable of reporting "tx bitrate" (it always
reports 6mbps). If you want to verify if the bitrate mask works you
must check "rx bitrate" on the other side, i.e. on the connected

Or just use a separate sniffer and see if AP is sends frames with
different txpower/bitrate values.


More information about the ath10k mailing list