[ath9k-devel] [PATCH v2 1/3] ath10k: implement device recovery

Kalle Valo kvalo at qca.qualcomm.com
Mon Jul 15 03:19:16 EDT 2013

Hi Michal,

sorry, I forgot to answer this one.

Michal Kazior <michal.kazior at tieto.com> writes:

> On 5 July 2013 09:47, Kalle Valo <kvalo at qca.qualcomm.com> wrote:
>> I feel that RESTARTING_OFF and RESTARTING_ON are a bit confusing names,
>> especially when we have OFF and ON states. Wouldn't RESTARTING and
>> RESTARTED be simpler?
> RESTARTING/RESTARTED seems confusing to me too. The whole thing
> shouldn't be considered restarted until mac80211 calls in
> restart_complete() - but then again, at that point we should consider
> the state as STATE_ON (and we do). Having RESTARTING_OFF / _ON gives
> off more info about the state hw is in.
> Ideally we should have only one state - RESTARTING and guarantee that
> the hw is in a workable state before we call in for
> ieee80211_restart_hw(). We'd need to skip hw startup in ath10k_start()
> in that case and make some code from ath10k_start() reusable and
> callable from ath10k_core_start().
> I can't really remember the reason I went with this particular design
> now. Perhaps this can be addressed in follow up patches later?

I would prefer that you still rename the states to what I suggested.

Kalle Valo

More information about the ath10k mailing list