[PATCH 05/15] Rename 'make_options' to 'kmake_opts'

Artem Bityutskiy dedekind1 at gmail.com
Wed Feb 5 07:10:34 PST 2014


From: Artem Bityutskiy <artem.bityutskiy at linux.intel.com>

The command-line option corresponding to the 'make_options' configuration knob
is called '--kmake-opts'. Let's be consistent and use the same names for both,
just to make things be more logical.

Alternatively, if 'kmake_opts' is not the best name, we could rename both to
'make_options' instead, or to something else.

Signed-off-by: Artem Bityutskiy <artem.bityutskiy at linux.intel.com>
---
 doc/email/example-aiaiai.cfg     | 2 +-
 email/aiaiai-email-sh-functions  | 4 ++--
 email/aiaiai-email-test-patchset | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/doc/email/example-aiaiai.cfg b/doc/email/example-aiaiai.cfg
index 3d26dff..4636e28 100644
--- a/doc/email/example-aiaiai.cfg
+++ b/doc/email/example-aiaiai.cfg
@@ -101,6 +101,6 @@
 
 	# Additional kernel build options which are appended to the end of the
 	# "make" command. For example, W=2 KALLSYMS_EXTRA_PASS=1.
-	make_options =
+	kmake_opts =
 
 # More "prj_xyz" sections may be added
diff --git a/email/aiaiai-email-sh-functions b/email/aiaiai-email-sh-functions
index 36c5564..a26fc51 100644
--- a/email/aiaiai-email-sh-functions
+++ b/email/aiaiai-email-sh-functions
@@ -162,7 +162,7 @@ parse_config()
 #
 # cfg_name. cfg_descr, cfg_path, cfg_configs, cfg_branch, cfg_reply_to_all,
 # cfg_accept_notify, cfg_always_cc, cfg_unwanted_keywords, and
-# cfg_make_options.
+# cfg_kmake_opts.
 #
 # If the project is not found, this function only defined an empty "cfg_name"
 # variable.
@@ -185,7 +185,7 @@ parse_prj_config()
 
 	cfg_always_cc="$(ini_config_get "$cfgfile" "prj_$prj" "always_cc")"
 	cfg_unwanted_keywords="$(ini_config_get "$cfgfile" ""prj_$prj"" "unwanted_keywords")"
-	cfg_make_options="$(ini_config_get "$cfgfile" "prj_$prj" "make_options")"
+	cfg_kmake_opts="$(ini_config_get "$cfgfile" "prj_$prj" "kmake_opts")"
 }
 
 # Compose (but not send) e-mail reply. This function assumes that the following
diff --git a/email/aiaiai-email-test-patchset b/email/aiaiai-email-test-patchset
index 97083b2..31e4345 100755
--- a/email/aiaiai-email-test-patchset
+++ b/email/aiaiai-email-test-patchset
@@ -340,7 +340,7 @@ aiaiai-test-patchset $verbose $preserve $bisectability $sparse $smatch $cppcheck
 	-i "$mbox" -j "$cfg_jobs" -c "$cfg_branch" -w "$tmpdir" \
 	${confdir:+-C "$confdir"} \
 	${cfg_unwanted_keywords:+-K "$cfg_unwanted_keywords"} -- \
-	${cfg_make_options:+-M "$cfg_make_options"} \
+	${cfg_kmake_opts:+-M "$cfg_kmake_opts"} \
 	"$cfg_path" "$cfg_configs" > "$tmpdir/test-patchset.log" ||
 {
 	verbose "aiaiai-test-patchset failed"
-- 
1.8.5.2




More information about the aiaiai mailing list